View current status of minerstat services.

21st June 2022

Increased HTTP Errors and Timeouts

Monitoring - A fix has been implemented and we are monitoring the results. Jun 21, 07:21 UTC

Identified - The issue has been identified and a fix is being implemented. Jun 21, 06:57 UTC

Investigating - Cloudflare is investigating wide-spread issues with our services and/or network. Jun 21, 06:43 UTC