View current status of minerstat services.

5th January 2023

my.minerstat.com Maintenance

Our systems are currently undergoing maintenance and may be partly operational. We are working to resolve any issues as quickly as possible and appreciate your patience during this time. Thank you for your understanding.

Update 15:27 UTC: There may be server outages or lockdowns at this time while we monitor the health of the servers.

Update 17:20 UTC: Server and infrastructure upgrade and move finished.